Jump to content

Toggle shoutbox Shoutbox Open the Shoutbox in a popup

@  dr3ad : (20 October 2018 - 03:52 PM)

Fixed the annoying downtime that would happen quite often. Server restarter is now working at 100% again

@  dr3ad : (09 October 2018 - 07:06 PM)

Fixed all client related Connection Issues & Errors. Just run .exe again

@  dr3ad : (15 September 2018 - 01:07 AM)

IMPORTANT ANNOUNCEMENT: For everyone having connection issues please redownload client from here!

@  dr3ad : (29 August 2018 - 07:05 PM)

Fixed all of the voting sites, now you can earn up to (3x3)x2 = 18 silver coins per day!!!

@  dr3ad : (10 August 2018 - 07:44 PM)

RPH: Battle for Azeroth + New Project (must read). View here.

@  dr3ad : (18 July 2018 - 11:31 PM)

If you're getting BLZ51900002 error change your DNS server settings to google's (if you dont know how to do this google it)

@  dr3ad : (04 July 2018 - 10:37 AM)

Fixed issue where some members would get "You're not allowed to visit this community" error

@  dr3ad : (30 June 2018 - 06:19 PM)

Added commands .gob massmove #EntryID #Distance #f/l/w/d/u & .gob massrel #EntryID #Distance #f/l/w/d/u (those two commands move all entries in specified direction, as well as .aura list which displays all "hidden" auras on the character

@  dr3ad : (27 June 2018 - 08:53 PM)

Added new commands .gob massreplace #EntryID #NewEntryID and .gob massscale #EntryID #Scale

@  dr3ad : (18 June 2018 - 03:21 PM)

Donator Extended rank has been changed a bit. Read more here.

@  dr3ad : (07 June 2018 - 10:24 PM)

RPHLite AddOn is now available for download, it's a must have addon and will ship with RPHTiny client by default from now on. Read more here.

@  dr3ad : (31 May 2018 - 02:35 PM)

New reward Book Forge has been added! Read more here.

@  dr3ad : (20 May 2018 - 10:53 PM)

You can get notified when player joins the phase if you're phase owner or have a rank. While having permission you can toggle messages with .toggleph

@  dr3ad : (20 May 2018 - 10:53 PM)

You can now auto promote players that join the phase with .ph auto #RankID command

@  dr3ad : (16 May 2018 - 11:52 PM)

.phase inplace command has been added that skips phase starting location (leaves you in place), however requires phase rank to use

@  dr3ad : (07 May 2018 - 09:53 AM)

Starting Area Contest has started and will last until 17th of May! View topic here.

@  dr3ad : (28 March 2018 - 08:57 AM)

Getting coins voting at XtremeTop100 fixed. Many additions to NPC Scripting. Check changelog.

@  dr3ad : (18 February 2018 - 06:31 PM)

Some NPC Script updates. Addition of Target Type "NPC with specific GUID" and Action "Pause Waypoint Movement", so now the scripts can finally target specific npc based on guid

@  dr3ad : (06 February 2018 - 04:29 PM)

Reminder that you can now chose in Rank Manager whether player can only manipulate (e.g delete) his own gobs/npcs. Phase owner can now also change color of specific phase ranks a.k.a name color in .ph ann

@  dr3ad : (25 December 2017 - 10:52 PM)

NPC scripts now work in all phases that you own, additionally phase ranks now contain "Can Use NPC Scripting" option, so everyone who has Scripting perk can now promote people and let them help with scripting the phase


Can't Change Faction

change faction cant

  • Please log in to reply
3 replies to this topic

#1 Blacksprut



  • Members
  • PipPip
  • 25 posts

Posted 14 June 2018 - 03:41 AM

I can't change my faction all of a sudden.


I have been trying to change the race of a dwarf to a goblin, but it's not working and it's been a few days that I've been trying, several server reset went buy, but nothing changes.

I input the command in game, log off, log back on, click the change faction icon next to the character, customize the dude, but once I confirm the dwarf stays a dwarf and the change faction icon stays there.

I tried to leave it be once I changed faction once after I used the command, waited for a reset and come but the icon was still there, my toon was still a dwarf, and if I clicked the icon again it tells me I have to change my race to the opposite faction when I chose goblin again. I tried to say what it asked and chose again dwarf and imput the command again in game, but nothing.


Tried change race, customize, login on other toons and try the command on other characters, the command works okay but my dwarf is still a damn dwarf!


What do I do?

#2 Generic DH

Generic DH


  • Donator
  • PipPipPipPip
  • 202 posts

Posted 14 June 2018 - 10:30 AM

You might have to log out after changing race, then log back in.


#3 Aruhiem


    Regular Member

  • Members
  • PipPipPip
  • 59 posts

Posted 14 June 2018 - 11:31 AM

That sometimes happens to me, when I change the faction but it remains the same I just click the change icon again, then press Back and it changes.

#4 Blacksprut



  • Members
  • PipPip
  • 25 posts

Posted 16 June 2018 - 01:11 AM

I tried both your methods, none of them change anything.

Also tagged with one or more of these keywords: change, faction, cant