Jump to content

Toggle shoutbox Shoutbox Open the Shoutbox in a popup

@  dr3ad : (28 February 2020 - 02:33 AM)

Server is now on patch 8.3. Please download new RPHTiny here https://rpheaven.org...nnection-guide/

@  dr3ad : (27 February 2020 - 12:42 AM)

Server is now under maintenance for 8.3, new connection guide will be posted in a bit.

@  dr3ad : (27 February 2020 - 12:01 AM)

Server going down for maintenance in 30 minutes for the upcoming 8.3 upgrade. New RPHTiny and announcement topic will be posted soon.

@  dr3ad : (04 February 2020 - 09:18 PM)

Waypoint (.wp) commands now work, additionally they have been changed to not require any arguments. E.g to add wp just select npc and do .wp add, .wp reload, .wp load

@  dr3ad : (14 January 2020 - 04:07 PM)

Server is back online and everything is working again. IMPORTANT: If you added any lines to hosts file now its time to delete them.

@  dr3ad : (03 December 2019 - 05:13 PM)

Added BFA NPCs to database. You can now also make 8.2/bfa NPCs in NPC forge. Also published list of 8.2 NPCs here and list of all BFA gameobjects here.

@  dr3ad : (20 November 2019 - 01:26 AM)

Fixed creation of custom items, all newly made items will now appear correctly. Also voting on Xtremetop100 now works and will award vote coins.

@  dr3ad : (08 November 2019 - 09:53 PM)

Performing minor maintenance, server up within 30 mins.

@  dr3ad : (07 November 2019 - 09:33 PM)

Minor downtime while some issues were worked on, server back online.

@  dr3ad : (07 November 2019 - 04:36 AM)

Item Forge now fully works with hidden (NPC) displays and custom items were wiped, however there won't be any more wipes in the future. Also .refresh no longer displays annoying goggles.

@  dr3ad : (05 November 2019 - 05:43 AM)

Server back online.

@  dr3ad : (05 November 2019 - 02:51 AM)

We are having some issues with the host machine, non related to RPH and we're working to bring server up asap.

@  dr3ad : (03 November 2019 - 08:04 PM)

Server back up, we shouldn't be seeing any long downtimes anymore as all issues have been addressed.

@  dr3ad : (03 November 2019 - 05:37 AM)

Server back online, had some downtime while installing server restarter on new host.

@  dr3ad : (02 November 2019 - 07:53 PM)

Server up also gameobjects are back, we had some downtime due to transfer to a new better host.

@  dr3ad : (02 November 2019 - 04:09 AM)

Download new 8.2.5 client here. Custom gameobject patch has been disabled temporary as we're fixing the way custom patch is streamed to the client. Custom gobs will be back within 24 hours.

@  dr3ad : (01 November 2019 - 10:26 PM)

We updated to 8.2.5 as we had some issues due to Blizzcon today removing 8.2.0 version from their content delivery network and hence half of people getting "Streaming error". We will post new 8.2.5 Wow.exe in couple of minutes, you just need to drag it into your existing RPHTiny/_retail_ folder.

@  dr3ad : (31 October 2019 - 05:19 PM)

Make sure to delete your cache folder if you experience freeze on character selection screen.

@  dr3ad : (30 October 2019 - 10:59 PM)

If you had problem where your RPHLauncher wouldn't launch at all, try again now.

@  dr3ad : (26 October 2019 - 02:57 AM)

Fixed crashes that were just happening due to crashy spell. Server up in 2 mins.


Photo
* * * * * 1 votes

8.3.0 BfA Connection Guide


  • Please log in to reply
10 replies to this topic

#1 Goudy

Goudy

    Administrator

  • Administrators
  • PipPipPipPipPipPipPipPip
  • 1758 posts

Posted 05 October 2019 - 05:04 PM

Getting invalid credentials? Make sure you're not logging in with forum account!


==== ONLINE====

Battle for Azeroth 8.3.0 (Build 33369)


Pre-requisites:
- 64-bit Windows (all versions that support Battle for Azeroth)
- Winrar or 7zip

How to play on RPH:
1) Start by creating an account here (forum account is separate!).
2) Download our client here It contains everything you need in order to connect and play. YOU MUST USE RPH LAUNCHER, NOT WOW.EXE
3) Extract RPHTiny_830BfA.rar (PUT IT ON C:\RPHTiny_BfA DRIVE DIRECTLY OR YOU'll GET CAS UNABLE TO INITIALIZE ERROR)
4) Run RPH Launcher.exe (do not run Wow.exe) and log in-game with your username@rph.org and respective password.

INFO: On ~25 mbit internet speed it will take about 20 minutes from starting RPH Launcher.exe until you can finally see other people in-game, so please be patient as all data is streamed.


How to play on RPH with old 8.2.5 RPHTiny (if you're new player skip this):

1) Download update here
2) Extract RPHFix_830.rar into your RPHTiny_BfA folder, hit replace when asked.
3) Run RPH Launcher.exe (do not run Wow.exe) and log in-game with your username@rph.org and respective password.


SOLUTIONS TO COMMON PROBLEMS

  • I ran Wow.exe and now I can't login?

A: You need to run RPH Launcher.exe to be able to login.

  • I ran RPH Launcher.exe but nothing happens?

A: Open Task Manager and check if Wow.exe is there, if it is then just leave it and give it some time (20 minutes on average if you have 25 mbit internet)

  • My WoW freezes, what do I do?

A: Close Wow.exe or give it some time to load (see question above)

  • Says invalid information when you try to log in?

A: Check that you're logging in with username@RPH.org and not just username.

  • Getting error BLZ51900003?

A: Make sure you entered your account information correctly.

  • Getting error BLZ51901017 or BLZ51901016 (unable to connect)?

A: Go into WTF folder and find Config.7z, extract its contains into the folder and then hit replace.

  • All players seem invisible and you can't see them?

A: Client is trying to stream data so please give it some time.

  • Other players missing equipment?

A: Type .refresh


  • dr3ad, Shaya, Purple and 21 others like this

#2 Lynight

Lynight

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 27 February 2020 - 02:40 AM

Ty



#3 HorrorMortar

HorrorMortar

    Regular Member

  • Members
  • PipPipPip
  • 39 posts

Posted 27 February 2020 - 02:40 AM

IT'S HERE


"Never done an honest day's work in your life for all that coin you're carrying, eh lad?"

I'm sorry, what? "I'm saying you've got the coin, but you didn't earn a septim of it honestly. I can tell."

How could you possibly know that? "It's all about sizing up your mark, lad. The way they walk, what they're wearing. It's a dead giveaway."

My wealth is none of your business. "Oh, but that's where you're wrong, lad. Wealth is my business. Maybe you'd like a taste?"

What do you have in mind? "I've got a bit of an errand to perform, but I need an extra pair of hands. And in my line of work, extra hands are well-paid."

What do I have to do? "Simple.... I'm going to cause a distraction and you're going to steal Madesi's silver ring from a strongbox under his stand. Once you have it, I want you to place it in Brand-Shei's pocket without him noticing."

Why plant the ring on Brand-Shei? "There's someone that wants to see him put out of business permanently. That's all you need to know. Now, you tell me when you're ready and we'll get started."

Why are we doing this to Brand-Shei? "We've been contracted to make sure Brand-Shei remember not to meddle in affairs that aren't his own. Now, since we're not the Dark Brotherhood, we're not going to kill him, we're just going to make sure he sits in the prisons for a few days."

How am I supposed to do all of this? "Do you want me to hold your hand as well? You're going to have to sneak to Madesi's stall and use your lockpick on the strongbox. Then when you have the ring, you pickpocket Brand-Shei and leave it behind."

I'm ready. Let's get this started...

 

bag23ta17xg11.jpg

 

magik.png

 

 

 


#4 Equanox

Equanox

    Newbie

  • Members
  • Pip
  • 3 posts

Posted 27 February 2020 - 02:56 AM

I have two launchers is this normal? one is called a Custom patch launcher?



#5 Khelbyn

Khelbyn

    the best of RPH

  • Donator
  • PipPipPipPipPip
  • 304 posts

Posted 27 February 2020 - 04:20 AM

I have two launchers is this normal? one is called a Custom patch launcher?

https://rpheaven.org...504-83-updates/


Posted Image

#6 Collector

Collector

    Your Friendly Lord of Change

  • Members
  • PipPipPipPipPip
  • 568 posts

Posted 27 February 2020 - 12:03 PM

Wait, which step do you need to follow if you were playing on 8.2.5?



#7 spiritgame

spiritgame

    Newbie

  • Members
  • Pip
  • 4 posts

Posted 27 February 2020 - 06:59 PM

Hello!

 

Me and a friend redownloaded the RPH tiny thing, and whilst it worked just fine for me... My friend did not share the same luck.

 

Apparently she's getting some sort of error about Initializing CAS for some reason. We made sure that her folder is located at the root of C: just as mine. We literally have the same thing in our computers, but for some reason it does not work for her. Here's a picture of the error she's getting.

555ec74d90d88d12fec4f98b5b5a0688-png.jpg

 

If you guys know why this is happening, and can help us out, it'd be of great help!

 

Thanks in advance.



#8 CinnamonBun

CinnamonBun

    Newbie

  • Members
  • Pip
  • 6 posts

Posted Yesterday, 09:08 AM

The holy grail's here

 



#9 Watari13

Watari13

    Newbie

  • Members
  • Pip
  • 1 posts

Posted Yesterday, 12:27 PM

Thanks for the update!

 

But I'm runnning into a but of an issue. Each time I launch the Custom Patch Launcher: 3jWgVdG.png

It says: Ther promgram can't start because VCRUNTIME140_1.dll is missing from your computer. Try reinstalling the program to fix this issue."

 

Granted, the launcher still starts depite this error, but is there a way to fix it? Or it's because I'm running this in Windows 8.1?



#10 Goudy

Goudy

    Administrator

  • Administrators
  • PipPipPipPipPipPipPipPip
  • 1758 posts

Posted Yesterday, 07:28 PM

Make sure you have the latest VC runetimes. It's likely the 2015 you are missing.

https://support.micr...ual-c-downloads



#11 xx1182

xx1182

    Newbie

  • Members
  • Pip
  • 2 posts

Posted Yesterday, 09:27 PM

What is this meme? I've tried downloading the game 2 times, and the second time i downloaded all them, and they all worked.